Total Pageviews

Showing posts with label CCIE VOICE. Show all posts
Showing posts with label CCIE VOICE. Show all posts

Monday, November 28, 2011

Voice Tips Tricks

How to hide users in Corporate Directory?

1. Create a file by the name hideuser.ldif (can be any name) in Notepad
2. Lets take the example of hiding ac user for Attendant Console. Put the following contents in the file and save it.
dn: cn=ac, ou=users, o=cisco.com
changeType:modify
replace:Description
Description:CiscoPrivateUser
3. Go to command line and run the following command.
ldapmodify -h <server name> -p 8404 -D “cn=Directory
Manager,o=cisco.com” -w <DCDAdmin Password> -c -f hideuser.ldif

Gatekeeper – Via zone behavior

How to trigger via zone behavior?
Local zones – always enable outvia on the destination zone
Remote zones – use invia or outvia on the remote zone
Via-zone gatekeepers differ from legacy gatekeepers in how LRQ and ARQ messages are used for call routing. Using via-zone gatekeepers will maintain normal clusters and functionality. Legacy gatekeepers examine incoming LRQs based on the called number, and more specifically the dialedDigits field in the destination Info portion of the LRQ. Via-zone gatekeepers look at the origination point of the LRQ before looking at the called number. If an LRQ comes from a gatekeeper listed in the via-zone gatekeeper’s remote zone configurations, the gatekeeper checks to see that the zone remote configuration contains an invia or outvia keyword. If the configuration contains these keywords, the gatekeeper uses the new via-zone behavior; if not, it uses legacy behavior.
For ARQ messages, the gatekeeper determines if an outvia keyword is configured on the destination zone. If the outvia keyword is configured, and the zone named with the outvia keyword is local to the gatekeeper, the call is directed to a Cisco Multiservice IP-to-IP Gateway in that zone by returning an ACF pointing to the Cisco Multiservice IP-to-IP Gateway. If the zone named with the outvia keyword is remote, the gatekeeper sends a location request to the outvia gatekeeper rather than the remote zone gatekeeper. The invia keyword is not used in processing the ARQ.

CCM Security – MGCP

crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
lifetime 10800
crypto isakmp key cisco address 10.1.1.1
crypto isakmp key cisco address 10.1.1.2
!
!
crypto ipsec transform-set CM esp-3des esp-sha-hmac
mode transport
!
crypto map CM 1 ipsec-isakmp
set peer 10.1.1.1
set transform-set CM
match address 101
crypto map CM 2 ipsec-isakmp
set peer 10.1.1.2
set transform-set CM
match address 102
!
access-list 101 permit ip host 10.2.2.2 host 10.1.1.1
access-list 102 permit ip host 10.2.2.2 host 10.1.1.2
interface Serial0/0.101 point-to-point
ip address 10.2.2.2 255.255.255.0
frame-relay interface-dlci 101
crypto map CM

How to prepend digits to caller id in H323?

voice translation-rule 1
rule 1 /\(^[2-9]………$\)/ /91\1/ — for national calls
rule 2 /\(.*\)/ /9011\1/ — for international calls
!
!
voice translation-profile ANI
translate calling 1

Meetme conference with announcing callers name facility

a. setup meetme conference, conf bridge as necessary. Let meetme number be 1900
b. setup a route point for calls from external and internal callers as the dial-in bridge number. Let this be  1800. Cfwdall this CTI route point to voice mail.
c. Setup a Call handler meetme in Unity. Under transfer settings, tell it to ring subscriber at extn 1900. Use Supervise transfer and Check Ask Caller’s name option.
d. Create a call routing rule under forwarded calls in Unity, and set teh Forwarding station to be 1800 (CTIRP). Attempt a transfer to callhandler meetme that you just created in step c.
Unity will ask the caller his name and transfer him to the conference bridge. Conference bridge members who already have joined the conference will hear, “Call from <callername>”

Allow caller input – Unity

Under caller input page, lock a key (0 through 9, * #) to a particular action if you want Unity to perform that action as soon as you press that key. The “Allow callers to dial an extension durin greeting” has no effect if the keys are locked. To allow callers to dial an extension during the greeting, dont lock the key to a particular action
If you have any of your keys set to Ignore key, the greeting that is played is usually System greeting “I do not recognize that as a valid selection”. This is the Error greeting. Expose the Error greeting using Advanced Settings tool from Tools Depot and you can re-record the Error greeting to a message of your choice.

Unity – Tips

The following tip may be utilized when you are asked to forward a call from CM / CME to Voicemail and have the caller leave a message. Then the message should be delivered to multiple user inboxes and also  light up mwi on the appropriate phones.
a. Setup CM/CME to forward calls to VM. (say  a route point with number  1005)
b. Create a PDL in Unity with members as the individual subscribers who needs to receive the message.
c. Create a Callhandler CH with number 1005. Go to Messages – > Message recipient and select this PDL you created in step 2.

IPIPGW Example

We setup a IPIPGW with 3 gatekeepers and 2 callmanagers.
IPPhone1—Callmanager 1—–GK1———–(IPIPGW/VIAZONEGK)———–GK2———Callmanager2—IPPhone2
GK1 configs:
int lo 0
ip address 172.12.100.1 255.255.255.0
gatekeeper
zone local HQ-RTR ipexpert.com 172.12.100.1
zone remote VIAZONE ipexpert.com 10.12.200.2 1719
zone prefix VIAZONE 20*
gw-type-prefix 1#* default-technology
no shutdown
!
GK2 Configs:
gatekeeper
zone local LT-RTR ipexpert.com 192.168.10.46
zone remote VIAZONE ipexpert.com 10.12.200.2 1719
zone prefix VIAZONE 40*
gw-type-prefix 1#* default-technology
no shutdown
IPIPGW config:
voice service voip
allow-connections h323 to h323
dial-peer voice 1010 voip
destination-pattern 20..
session target ras
incoming called-number 40..
dtmf-relay h245-alphanumeric
codec transparent
!
dial-peer voice 1020 voip
destination-pattern 40..
session target ras
incoming called-number 20..
dtmf-relay h245-alphanumeric
codec transparent
!
int fa0/0
ip route-cache same-interface
h323-gateway voip interface
h323-gateway voip id VIAZONE ipaddr 10.12.200.2 1719
h323-gateway voip h323-id PSTNSw
h323-gateway voip tech-prefix 1#
VIAZONE GK Configs:
gatekeeper
zone local VIAZONE ipexpert.com 10.12.200.2
zone remote HQ-RTR ipexpert.com 172.12.100.1 1719 invia VIAZONE outvia VIAZONE
zone remote LT-RTR ipexpert.com 192.168.10.46 1719 invia VIAZONE outvia VIAZON
E
zone prefix LT-RTR 20*
zone prefix HQ-RTR 40*
no shutdown

IPCC High Availability

When you install two IPCC servers the following considerations hold true:
a. The first server you activate (CRS Engine and/or Datastore services) will become the active CRS box.
b. The second server you activate (CRS Engine) will become the standby box for the active CRS engine.
c. The second server you activate (Datastore engine) will become the standby box for the active Datastore engine. (Agent, Historical etc).
d. When you create a jtapi user in the active box (first server in your cluster), the user name that is created in Callmanager is “jtapi_1″ the one signifying that its the jtapi user for the first CRS server. When you install the second CRS server, it will create another jtapi user named “jtapi_2″.
e. The second server that you install will use the administrator username / password of the first box during the initial server setup. You should not use Administrator / ciscocisco password.
f. If the active box has a jtapi group with 20 CTI ports ranging from 3201 to 3220, when you initialize the standby box, it will automatically create 20 more CTI ports from 3221 to 3240.
g. JTAPI groups that are created in IPCC coressponds to CTI ports created in Callmanager. The ports in Callmanager that belong to the active CRS box will have a description (if you leave it at defaults) as JTAPI Group #0 – 1. The ports that belong to the standby CRS box will have a description JTAPI Group #0 – 2

After hours block pattern (significance of time)

Lets look at an example where you want to block international calls outside of business hours 8 am to 5 pm.
Remember the time you should configure is in 24 hours format. So 5 pm is 17:00.
after-hours block pattern 1 9011
after-hours day Sun 17:01 08:59
after-hours day Mon 17:00 08:59
after-hours day Tue 17:00 08:59
after-hours day Wed 17:00 08:59
after-hours day Thu 17:00 08:59
after-hours day Fri 17:00 17:00
after-hours day Sat 17:01 17:00
If you specify the time as 08:59, it includes the 60 seconds from 08:59:00 to 08:59:59. So calls will be blocked until 08:59:59. If you specify the time as 17:00, calls will be blocked till until 17:00:59.

VT advantage – unlimited

VTA uses CAST protocol. Uses 4224 TCP port. This protocol helps in discovering remote VTA capable endpoints, communicates with IP phone as well as with Callmanager. To ensure proper QOS is given to CAST, on the phone port, create a service policy to mark TCP 4224 with DSCP CS3.
VTA uses two types of codecs.
a. H263 – min of 128kbps to a max of 1.5 Mbps per call
b. Wideband – 7.0 mbps per call

MGCP Call Preservation

MGCP PRI backhaul does not support call preservation when transitioned from Callmanager to SRST and vice versa.

H323/MGCP – Caller ID Display

H323 does not support Facility IE. H323 supports only Display IE
MGCP supports both Display and Facility IE

Frame-relay fragment

Frame-relay fragment is typically not needed for link speeds above 768 kbps.
If CIR is 256k and link speed is 480kbps, frame-relay fragment should be based off of PVC CIR ie 256 K.

MGCP Fallback to H323

application
global
service alternate Default
ccm-manager fallback-mgcp
sh ccm-manager
MGCP Domain Name:
Priority Status Host
============================================================
Primary Down 10.101.21.250
First Backup Down 10.102.21.251
Second Backup None
Current active Call Manager: None
Backhaul/Redundant link port: 2428
Failover Interval: 30 seconds
Keepalive Interval: 15 seconds
Last keepalive sent: 19:46:24 UTC Mar 5 1993 (elapsed time: 00:43:26)
Last MGCP traffic time: 19:46:33 UTC Mar 5 1993 (elapsed time: 00:43:17)
Last failover time: 14:36:07 UTC Mar 5 1993 from (10.100.1.50)
Last switchback time: 14:36:13 UTC Mar 5 1993 from (10.100.1.51)
Switchback mode: Graceful
MGCP Fallback mode: Enabled/ON
Last MGCP Fallback start time: 19:46:52 UTC Mar 5 1993
Last MGCP Fallback end time: 19:45:24 UTC Mar 5 1993
MGCP Download Tones: Disabled
Backhaul/Redundant link is down
Configuration Error History:
FAX mode: cisco
To simulate MGCP fallback, do not disable MGCP using the no mgcp command. This will not kick in the H323 fallback mode. Either apply an access list or create a null route for Callmanager server.

Dial-peer matching

It follows the longest match rule first and then preference. In this example, if you dial 2001, dial-peer 10 will be matched first (longest match + preference 1) and then dial-peer 11 (longest match + preference 2) and then dial-peer 11 (next best match)
dial-peer voice 10 voip
preference 1
destination-pattern 2001
voice-class h323 1
session target ipv4:10.100.1.51
ip qos dscp cs3 signaling
!
dial-peer voice 11 voip
preference 2
destination-pattern 2001
voice-class h323 1
session target ipv4:10.100.1.51
!
dial-peer voice 12 voip
destination-pattern 200.
session target ipv4:10.100.1.50

IOS interpretation of “\”

IOS maps “\” followed by a number to a character. For ex: “\320″ maps to the alphabet “P”.
If you need to use this combination, then use the escape key sequence “\134″ before the numbers. In the same example, use “\134320″

MLPP

How to setup basic MLPP ?
a. Take three phones 1025, 1026 and 1027. Let 1025 be the destination phone. 1026 be able to make Exec Override calls. 1027 be able to make Flash Override calls.
b. Set them all up in same MLPP domain 000011 (for ex:)
c. Set 1025 with MLPP indication enabled, Premption – Forceful
d. Set 1026 and 1027 with MLPP indication enabled, Premption – Can be disabled. No need to set them to forceful.
e. Create translation pattern 90.1025 in partition Exec and set the MLPP setting to Executive Override. This TP can be accessed only by 1026. Translate 90.1025 to 1025.
f. Create translation pattern 90.1025 in partition Flash and set the MLPP setting to Flash Override. This TP can be accessed only by 1027. Translate 90.1025 to 1025.
g. Place a flash override call from 1027 to 1025. (Dial 90.1025 from 1027.). You should note a different ring tone on 1025 and also a precedence ringer display.
h. Place a exec override call from 1026 to 1025 (Dial 90.1025 from 1026). You should immediately hear a precedence tone on 1025 and 1027. (Continous tone). Both parties 1025 and 1027 have to independently hangup. The Exec override call from 1026 is offered to 1025. Phone 1025 starts ringing.
i. If 1025 doesnt answer the exec override call from 1026, after 30 seconds, the call between 1025 and 1027 is dropped and the exec override call from 1026 is offered to 1025.
j. A flash override call cannot preempt a exec override call. If 1026 and 1025 are in a exec override call, a flash override call from 1027 cannot preempt the call between 1026 and 1025, as the flash override call has lower precedence. The flash override call will appear as call waiting on 1025. (No call waiting beep is heard).
k. An exec override call cannot preempt another exec override call (same domain), unless the service parameter Exec Override Call Preemptable is set to true. With the default setting (false), if 1026 places an exec override call to 1025, and 1027 places an exec override call to 1025, this call will appear as call waiting on 1025. (No call waiting beep is heard).
l. Do not set Preemption enabled to Forceful and Premption indication to Off of Default (If device pool is also off). This will prevent preemption on the destination device.
m. Only calls originating from devices in same domain can be prempted. If 1026 is set to domain 000011 and 1027 is set to domain 000022, 1026 cannot override 1027′s call and vice versa.
n. If both 1026 and 1027 are set to flash override, One flash override call cannot preempt another flash override call. The call appears as call waiting (no beep is heard)

Fax passthrough – unlimited!!

What is Fax passthrough ?
Fax passthrough encodes fax traffic with in a g711 voice codec and sends it across the voip network as a voice call. The call may use any codec (g711, g729, g723) etc initially and once a 2100 Hz CED tone is detected, the device (ATA for ex:) tells the far end gateway to switch over to G711 using a peer-to-peer message. This message is called a NSE message (Named Signalling Event) with in the RTP stream.

QoS templates for 3550

1. mls qos
### enables qos globally#######
2. mls qos cos-map 0 8 16 26 34 46 48 56
### maps cos values to dscp values properly######
3. For IP phones ports, apply the following commands
int range fa 0/1 , fa 0/2
#### ip phone ports
flowcontrol receive off ***** important command********
flowcontrol send off *********important command*******
4. Mapping voice bearer traffic in priority queue
int fa0/1
wrr-queue cos-map 4 5
priority-queue out
### if asked to put Voice bearer in priority queue
5. Mapping voice signalling traffic in queue 3
wrr-queue cos-map 3 3
6. Port configuration
interface fa0/1
mls qos trust cos
#### trusts packet cos
mls qos trust device cisco-phone
#### trusts cos only if a phone is attached
switchport priority extend cos 0
### zeros out PC cos values.
7. If asked to modify bandwidth and buffer settings for each queue (only then do the following)
For fastE ports:
mls qos min-reserve 5 170
mls qos min-reserve 6 130
mls qos min-reserve 7 51
mls qos min-reserve 8 34
#### defines min-reserve levels (upto 8 levels may be defined, default buffer size is 100 for all levels)####
int range fa 0 /1, fa 0/2
wrr-queue bandwidth 20 20 60 1
### priority queue doesnt need wrr bandwidth allocation
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
### maps min-reserve levels to queues#####
For GigE ports:
int range gi 0/1 , gi 0/2
wrr-queue queue-limit 60 20 20 1
#### defines more buffer space for low priority queue ####
wrr-queue bandwidth 20 20 60 1
8. DSCP maps (optional)
For gig ports there is a dscp map that maps dscp values to thresholds.
Each queue has two thresholds, and by default all dscp values are mapped to threshold 1.
If asked to set voice traffic (may be video) to threshold 2, use command.
wrr-queue dscp-map 2 26 34 46 (this is higher threshold in the queue)
9. Tail Drop or WRED (optional)
For gig ports default drop mechanism is tail drop. Here is how you may modify these thresholds:
wrr-queue threshold 1 80 100
wrr-queue threshold 2 80 100
wrr-queue threshold 3 80 100
### no need to define drop thresholds for queue 4 if its priority queue
To enable WRED and specify thresholds, use following commands:
wrr-queue random-detect max-threshold 1 80 100
wrr-queue random-detect max-threshold 2 80 100
wrr-queue random-detect max-threshold 3 80 100
### WRED and tail drop are mutually exclusive
10. Classification using ACLs.
To classify based on subnet, define standard or extended acl’s.
access-list 101 permit ip any any dscp 24
class-map test
match access-group 101
11 .Defining Policer and Remarking traffic
mls qos map policed-dscp-map 26 46 to 0
#### remarks voice control and bearer traffic to dscp 0. (Defined in policer)
mls qos aggregate-policer TestPolicer 256000 8000 exceed-action policed-dscp-transmit
#### defines an aggregate policer with a rate of 256kbps, burst of 8000 bits and remarks dscp for voice and bearer traffic based on above policed-dscp map
class-map match-all Voice
match ip dscp af31 ef
policy-map Voice
class Voice
trust dscp
police aggregate TestPolicer
#### applies aggregate policer to the class.
You cannot define same policer across multiple policy-maps.
int range fa 0/1 , fa0/2
service policy input Voice
Example configs:
1. To define a class-map that remarks traffic:
——————————————
class-map match-all VoiceControl
match ip dscp af31
class-map match-all VoiceBearer
match ip dscp ef
policy-map Voice
class VoiceControl
trust dscp
set ip dscp 40
class VoiceBearer
trust dscp
set ip dscp 24
int range fa 0/1 , fa0/2
service policy input Voice
2 . To perform per-vlan, per-port classification, marking, policing. (may be required on gateway ports which may be a trunk port)
—————————————————————
class-map match-all Voice
match ip dscp af31 ef
class-map match-all VoiceVLAN
match vlan 100 ————– defines which vlan you want to match
match class-map Voice ——- defines all traffic on voice vlan with dscp af31 or ef.
policy-map Voice
class VoiceVLAN
trust dscp
police aggregate TestPolicer
#### applies aggregate policer to vlan 100
You cannot define same policer across multiple policy-maps.
int range fa 0/3
Decription Gateway port
service policy input Voice
3. To perform individual policing on each class:
———————————————-
mls qos map policed-dscp-map 26 46 to 0
class-map match-all Voice
match ip dscp af31 ef
policy-map Voice
class Voice
trust dscp
police 256000 8000 exceed-action policed-dscp-transmit
####This is a individual policer
int range fa 0/1 , fa0/2
service policy input Voice

QOS template for 6500 – Egress

Mapping packets to a particular queue / threshold
set qos map 2q2t tx 2 1 cos 3 (mandatory)
Optional commands:
set qos wrr 2q2t 5 255 (optional)
The values are absolute based on a scale of 255. To get the values in percent, you need to multiply it by 2.5.10% means 25 and 20% means 50 and so forth.
set qos drop-threshold 2q2t tx queue 1 80 100
OR
set qos wred 1p2q2t tx queue 1 80 100 (both optional)
set qos drop-threshold 2q2t tx queue 2 80 100
OR
set qos wred 1p2q2t tx queue 2 80 100 (both optional)
set qos txq-ratio 2q2t 80 20 (optional)

CM 4.1 ports (important) — all ports are destination ports unless specified

Intracluster ports:
SQL TCP 1433, 3372
SMB TCP 445
ICCS – TCP 8002, 8003
Windows common ports:
DHCP (if running) – UDP 67,68
TFTP – UDP 69
Signalling ports:
skinny TCP 2000, (from phone to CCM)
secure skinny TCP 2443 (from phone to ccm)
tftp -udp 69 and ephemeral ports
capf – tcp 3804 (phone to capf/ccm)
RTP – udp 16384 – 32768 (CM uses only 24576 – 32767)
VTAdvantage (TCP 4224) – PC to the phone
Callmanager to gateway
tcp port 11000 – 11999
tcp port 1024 – 4999
tcp port 1720 bothways (h225)
tcp port 2000 (skinny gateway to ccm)
udp 2427/ tcp 2428 (mgcp gateway control/backhaul)
tcp and udp port 5060 (SIP gtway and ICT)
udp port 16384-32767 – RTP between the gtwy and cm
Callmanager to gatekeeper
tcp port 1718 (ccm to gk)
udp port 1719 (gk to ccm)
Callmanager to gateway (for encryption)
ESP – 50 (ESP protocol itself)
IKE – 500 UDP
Callmanager to Secure SRST router
SRST Certificate Provider Port: 2445

CCM User – CTI Application use vs CTI Super Provider

When CTI Application use is checked, the user can control the devices associated to that user.
When CTI Super Provider is checked, the user can control all CTI ports, CTI Route Points and IP Phones.

CME – CUE – MWI setting

For CUE you need to define mwi on and off as two different ephone-dn’s. You cannot enable the mwi on-off using the same ephone-dn like you do with Unity.
Set up the mwi number following by dots equal to the extension length
ephone-dn 10
number 1599….
mwi on
ephone-dn 11
number 1598….
mwi off
The default ccn application for mwi uses the extensions 8000 for ON and 8001 for OFF. You can change this from CLI
ccn application ciscomwiapplication
description “ciscomwiapplication”
enabled
maxsessions 4
script “setmwi.aef”
parameter “strMWI_OFF_DN” “1598″
parameter “strMWI_ON_DN” “1599″
parameter “CallControlGroupID” “0″
end application
1. When the extension appears on line 1, red lamp MWI and envelope is used.
2. When the extension appears on any line other than line 1, only envelope is used.

Unity Express – Changing IP Address

After changing the IP Address in the interface service-module, calls to voicemail are getting answered, but callers does not hear anything.
The show call active voice brief shows that the call leg to unity express is getting connected to the old IP address.
Resetting the CUE fixed the issue.

Unity Live Reply – Gotchas

If subscriber has Standard conversation, he needs to press 4-4 after the message has been played (including message footer).
If subscriber has Optional conversation1, he needs to press 8-8 after the message has been played (including message footer)
When subscriber (called) presses 4-4 or 8-8, Unity checks the original subscriber’s (who left the voice message) transfer settings and sends the call based on his transfer settings. You may have to change the setting from “Send to greeting” To “Ring subscriber’s extension” or “Ring subscriber at XXXX”.

CME – Caller name display

Prime line – Caller name display while ringing and when connected
Other lines – Caller name display only when connected
To enable Caller name display,
telephony-service
service dnis overlay  (For overlaid phones)
service dnis dir-lookup (Look up names from directory-entry command)

Soft phone local time display

Soft phones derive time from the local PC and not from Callmanager / CME.
ATA 186 auto registration
To disable auto registration for any of the port set Sid 0 or Sid1 to 0 or empty. This will disable the port and not attempt a registration with CM. If you want to manually add the port in CM, put Sid0 or Sid1 as the mac-address of the appropriate port.

MGCP & H323 IOS gateway and T38 faxing

MGCP gateways and T38
1. mgcp fax t38 ls_redundancy 0  OR
mgcp fax t38 hs_redundancy 0
ls_redundancy set to 0 disables mgcp from sending redundant packets. The value can be set from  0  – 5 or 7 packets
hs_redundancy set to 0 disables mgcp from sending redundant packets for high speed fax m/c v.17, v27, v29 T.4 or T.6 fax machine. Default is 0, Can be configured up to 2 or 3.  0 disables redundancy.
Optional commands:
mgcp fax t38 gateway force  – This command forcest38 fax relay using NSE’s eve if T38 and NSE’s cannot be negotiated by the MGCP call agent at call setup time
mgcp fax t38 inhibit – Disables MGCP T38 fax relay.
mgcp tse payload <value>  – TSE is for Telephony signalling event. This command specifies payload value during fax and modem passthrough. Default is 100.
mgcp fax rate <rate>|voice  (Default rate is 7200 bps)
H323 gateways and T38
dial-peer voice 1 voip
fax rate voice
fax protocol t38 ls_redundancy 0
options available are :
force – forces use of NSE;s to switch to T38 fax relay
fallback pass-through  g711ulaw | g711alaw – A fallback mode if T38 could not be negotiated.

MGCP IOS gateway and ATA 186 in H323 mode – Fax Passthrough configuration

1. Configure MGCP gateway as usual (with FXS ports).
2. Give the following commands
no ccm-manager fax protocol   — disables cisco fax relay
mgcp modem passthrough voip mode nse  — enables modem passthrough
mgcp modem passthrough voip codec g711ulaw
MGCP default NSE payload types
Output of “Sh mgcp”
MGCP media bind ISABLED
MGCP Upspeed payload type for G711ulaw: 0,  G711alaw: 8 (You may opt to match this up with ATA NSE payload type)
MGCP Dynamic payload type for G.726-16K codec
MGCP Dynamic payload type for G.726-24K codec
3. Optionally you may want to disable T38 fax relay for MGCP (which is enabled by default)
mgcp fax t38 inhibit. (Useful if you want to just have passthrough enabled, and disable t38 fax on the gateway)

ATA 186 Fax modes (H323)

Fax pass through – Set audio mode to 0×00150015
Fax mode – (Use direct g711 only, it doesn’t do any codec upspeed.) – Set audiomode to 0×00120012
12 – corresponds to 0001 0010
bit 1 – set to 1 for g711 only
bit 2 – set to 0 to disable CED

DSCP settings for H323 and MGCP gateways

The setting below applies to packets generated by teh router itself.
For H323 gateways
Default for signaling is af31 (26). Need to change this to cs3 (24).
dial-peer voice 1500 voip
ip qos dscp cs3 signaling
For MGCP gateways
mgcp ip qos dscp cs3 signaling

IOS gateways – faxing – three steps

To enable fax passthrough in a H323 IOS gateway: (This can be given under a dial peer or globally under voice service voip mode)
Global mode:
1.  modem passthrough nse [payload-type number] codec {g711ulaw|g711alaw} [redundancy] [maximum-sessions <value>]
* Payload-type default : 100 for IOS gateways (Set this to same for all other gateways)
* Codec should be g711ulaw for fax sent over a t1 trunk or g711alaw for fax sent over a e1 trunk
* redundancy – enables fax redundancy. Set this parameter to be same at both ends
* max sessions – defines how many fax calls can occur simultaneously. Default is 16. Valid values 1 – 26.
2. Disable Fax relay – Fax relay is enabled by default and takes precedence over Passthrough.
fax rate disable
3. If you gave the modem passthrough setting under voice service voip mode, then you need to give the following command in dial-peer mode.
dial-peer voice 1 voip
modem passthrough system
Dial-peer mode: (2 steps)
If you choose not to apply the modem passthrough settings in global mode, dial-peer voice 1 voip
fax rate disable
modem passthrough nse codec g711ulaw
To enable Fax passthrough in a Cisco IOS MGCP gateway
no ccm-manager fax protocol cisco
mgcp modem passthrough voip mode nse
mgcp modem passthrough voip codec g711ulaw|g711alaw.

H323 – ATA fax passthrough setting – recommendations

Audiomode – 0×00150015
0000 0000 0001 0101 (last 4 hex digits represents phone 1)
Bit 0 – 1 enables VAD
Bit 2 – 1 enables fax CED tone detection
Connect mode : 0×90000400
1001 0000 0000 0000 0000 0100 0000 0000
Bits 12 – 8 represent NSE payload type offset. Default NSE payload type is 100 for ATA which means the offset is set to 4 (00100). IOS H323/SIP gateways use NSE payload type 100. Most MGCP gateways using 6608 uses NSE payload type 101. So set the offset to 5 (00101) if setting up fax between ATA and 6608 (older versions)
Bits 13 – default 0 – represents fax pass through codec. 0 means g711ulaw, 1 means g711alaw.
To use fax in countries other than US, set
Connect mode : 0×90002400
**** key things to remember about interoperability of various AVVID fax components******
If a VG248, Cisco IOS router, MGCP gateway and ATA 186 is involved in faxing. Then set the NSE payload type to 100 (IOS Mode) in all devices. In VG248 set to IOS mode. In router by default NSE payload type is 100 (for modem passthrough). In MGCP IOS gateway (need to check). In 6608 set the mode to IOS mode. In ATA 186, default NSE payload type is 96 + offset of 4 = 100.

Fax passthrough – unlimited!!

What is Fax passthrough ?
Fax passthrough encodes fax traffic with in a g711 voice codec and sends it across the voip network as a voice call. The call may use any codec (g711, g729, g723) etc initially and once a 2100 Hz CED tone is detected, the device (ATA for ex:) tells the far end gateway to switch over to G711 using a peer-to-peer message. This message is called a NSE message (Named Signalling Event) with in the RTP stream.

ATA 186 H323 Audio parameters

LBRCodec:
If LBRCodec is set to 0, ATA chooses g723.1 as the Low bit rate codec. (You can have up to 2 calls on the ATA at g723.1)
If LBRCodec is set to 3, ATA chooses g729 as the Low bir rate codec (Only one call can be there on the ATA at g729). The allocation of g729 to either ports is dynamic. (Unlike SCCP, where the Connect mode bit 21 determines which port will use g729)
Audiomode
Audiomode has 32 bits. First 16 bits set parameters for Phone port 1, Upper 16 bits set parameters for Phone port 2.
Default : 0×00150015
0000 0000 0001 0101 0000 0000 0001 0101
Bit 0 and 16 – Disable VAD (0 – Disable, 1 – Enable)
Bit 1 and 17 – if set to 1, enable g711 only. If set to 0 Enable LBR along with g711.
Bit 2 and 18 – if set to 1 enables fax CED tone detection
TxCodec:
To specify transmit audio codec preference
0 – g723 (only if LBRCodec is 0)
1 – g711alaw
2 – g711ulaw
3 – g729a (only if LBRCodec is 3)
RxCodec
0 – g723 (only if LBRCodec is 0)
1 – g711alaw
2 – g711ulaw
3 – g729a (only if LBRCodec is 3)

Networking ATA, Callmanager and Voice gateway with FXS (phones)

Setup :
a. Callmanager 4.1 with IP phone extension 1005 (Callmanager IP 192.168.1.200)
b. ATA 186 with H323 load , 2 phones with extension 2000, 2001 (ATA IP 192.168.1.46)
c. H323 gateway with FXS ports with phone extension 3010, 3011 (Gateway IP 192.168.1.202)
d. Gatekeeper with 3 zones created (one for CM, one for gateway and one for ATA) (GK IP 192.168.1.201)
******Key things to note about GK registration*******
a. ATA register with GK as Terminal
b. H323 gateway registers with GK as Voip-GW
c. Callmanager can be registered to the GK as Voip-GW or Terminal (Trunk configuration page)
d. GK uses proxying between Terminals and Voip-GW’s. So take special note to disable proxy from each zone that involes a Terminal and Voip-GW.
Configuration of ATA
a. Use E164 numbers in UID0 and UID1.
b. No need to set Login ID’s if using E.164 numbers for GK registration
c. Specify the GKID field with the zone name (with out domain name)
d. Specify the GKOrProxy field with the IP address of the gatekeeper (192.168.1.201)
e. ATA cannot specify a tech prefix (as it registers as a terminal)
Configuration of GK
GateKeeper#sh gatek end
GATEKEEPER ENDPOINT REGISTRATION
================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    F
————— —– ————— —– ———         —-    –
192.168.1.46    1721  192.168.1.46    1739  ATA               TERM
ENDPOINT ID: 8232D55C00000001  VERSION: 2 age= 233 secs
E164-ID: 2001
192.168.1.46    1720  192.168.1.46    1719  ATA               TERM
ENDPOINT ID: 82609CF000000002  VERSION: 2 age= 233 secs
E164-ID: 2000
192.168.1.200   55419 192.168.1.200   53824 CM41              VOIP-GW
ENDPOINT ID: 824FC0F400000004  VERSION: 2 age= 18 secs
H323-ID: CCM_1
192.168.1.202   1720  192.168.1.202   50439 gateway           VOIP-GW
ENDPOINT ID: 8230A09400000004  VERSION: 2 age= 40 secs
H323-ID: 192.168.1.202
E164-ID: 3011
E164-ID: 3010
Total number of active registrations = 4
GateKeeper#
Gateway Configuration
interface Ethernet0/0
ip address 192.168.1.202 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id gateway ipaddr 192.168.1.201 1719
h323-gateway voip h323-id Gateway
h323-gateway voip tech-prefix 1#
dial-peer voice 1 pots
destination-pattern 3010  —– phone 1
port 1/0/0
!
dial-peer voice 2 pots
destination-pattern 3011  —– phone 2
port 1/0/1
dial-peer voice 10 voip
destination-pattern 1…      —— Pattern for calls to Callmanager , No need to prepend tech prefix as 4# is  default tech prefix
session target ras
dtmf-relay h245-alphanumeric
codec g711ulaw
!
dial-peer voice 10 voip
destination-pattern 2…     ——- Pattern for Calls to ATA, No need for tech prefix as ATA registers to GK as terminal
session target ras
dtmf-relay h245-alphanumeric
codec g711ulaw
!
gateway
Configuration of Callmanager
a. Add a gatekeeper (with GK’s ip address, 192.168.1.201)
b. Add a Trunk (Gatekeeper controlled) and specify tech prefix 4#, the gatekeeper that was previously added, Terminal type (VOIP-GW or Terminal)  and zone name (CM41)
c. Set the significant digits on incoming calls to All.
d. Add a route pattern [23]XXX and route the calls through the trunk created in step 2. 2XXX is for ATA phones and 3XXX is for FXS phones

Basic H323 parameters – ATA in H323 mode

UID 0 – E.164 number of port 1, UID 1 - E.164 number of port 2. This is effective only if UseLoginID = 0.
LoginID 0 – H323 ID of port 1, LogingiD1 – H323 ID of port 2. This is effective only if UseLoginID = 1 (default 0)

ATA 186 SCCP config page reference


If the pic is not legible, download the picture and zoom it to see more clearly.

How to reset ATA 186 to factory defaults

1. Pickup phone handset and press ATA function button
2. Dial FACTRESET#. The IVR will say press * to save or to exit press # key. Press * to save and it should reset the ATA to factory default configuration.

TOS bit setting (SCCP)

Default value :0x000068b8
0110 1000 1011 1000 (ignoring leading 0′s)
0-7 digits represents RTP payload. Maps to DSCP 46 or TOS 5 (leading 3 digits 011)
8 – 15 digits represents Voice signalling. Maps to DSCP 26 or TOS 3 (leading 3 digits are 101)
To change the voice signalling to DSCP 24 (according to CM 4.1 specs) the new value of TOS is
0x000060b8     (Change bit 11)

Audiomode settings for ATA (SCCP)

Default value : 0×00350035
32 bit field, first 16 bits for phone 1 and second 16 bits for phone 2 (starting from LSB)
0000 0000 0011 0101    0000 0000 0011 0101
a. To force g711 on all calls set bit 1 and 17 to 1 – Audiomode becomes 0×00370037  (Both ports are forced to use g711)
b. To use low bit rate codec or g711 (default setting) – set bits 1 and 17 to 0 – Audiomode becomes 0×003500035
Fax CED tone detection
Bits 2 and 18 should be set to 1 (default) to enable Fax CED tone detection
If set to 0, tone detection is disabled.

Fax between ATA on port 2 and Router with FXS (g729 codec)

Fax setup that works:
Fax on port 2 of ATA, LBRcodec = 3, Connect mode bit 21 = 1.
Router has dial-peer with g729r8 (br8) codec and fax machine on FXS port.
Commands in dial-peer:
dial-peer voice 10 voip
codec g729r8|br8
modem passthrough nse codec g711ulaw
fax rate disable
fax protocol pass-through g711ulaw
Fax setup that didnt work
Fax on port 2 of ATA, LBRcodec = 3, Connect mode bit 21 = 1.
Router has dial-peer with g729r8 (br8) codec and fax machine on FXS port.
Commands in dial-peer:
dial-peer voice 10 voip
codec g729r8|br8
fax rate disable
fax protocol pass-through g711ulaw
Conclusion : With out modem passthrough, Fax passthrough on routers are not working!

LBRCodec and Connect Mode (Skinny)

LBRCodec can take 2 values 0 or 3.
ATA can support following codec. g723, g729, g729a, g711(a/u).
Both ports can support g723 at same time
Both ports can support g711 at same time
Only one port can support g729 at any time.
Port 2 doesnt have support for g729a. Port 1 has.
When LBRCodec = 0,
port 1 and 2 can use g711ulaw, g711alawor g723.1
When LBRCodec =3 and Connect mode  bit 21 = 0 (affects only g729)
Port 1 can use g711ulaw, g711alaw, g729a or g729
When LBRCodec=3 and Connect mode bit 21 = 1 (affects only g729)
Port 2 can use g711ulaw, g711alaw, g729

ATA SID (Sccp)

ATA 186 SID 0 is for phone port 1
ATA 186 SID 1 is for phone port 2
If set to 0, phone port is disabled and doesnt register with CCM.
If set to . (dot), ATA port uses its default mac-address (port 2 uses 01 appended at the end) to register with CCM

ATA 186 -setting static Vlan ID in ATA (SCCP)

You will have to use OpFlag and Vlan setting fields.
Opflag:
Default value of OpFlag is 0×000000002
0000 0000 0000 0000 0000 0000 0000 0010  — bits 4,5,6 are set to zero by default which acquires VLAN ID via CDP. To disable this setting and set this to static, use 101 in bits 4,5,6
0000 0000 0000 0000 0000 0000 0101 0010  — 0×00000052
VLAN Setting:
Default setting is 0x0000002b
Translates to 0000 0000 0000 0000 0000 0000 0010 1011
Set bits 18 through 29 with VLAN ID. IF you have to set VLAN ID to 115, 115 translate to
64 + 32 + 16 + 0 + 0 + 2 + 1 = 01110011
0000 0001 1100 1100 0000 0000 0010 1011
which translate to 0x01cc002b
Cos bits for Signalling and RTP ( first 6 bits of Vlan setting)
0000 0001 1100 1100 0000 0000 0010 1011
First three bits (0-2) are for voice signalling. By default this is set to 3.
0000 0001 1100 1100 0000 0000 0010 1011
Second three bits (3-5) are for voice bearer (rtp). By default this is set to 5.

ATA 186 basics

1. To add ATA 186 port 1 enter the mac-address of ata 186
2. To add ATA 186 port 2 drop leading 2 digits of mac-address and add a 01 to the end.
3. To enable DHCP via phone, hit the red menu button on ATA and choose option 20# and choose 0 for disable dhcp, 1 for enable dhcp
4. To configure IP address via phone chooose option 1#. Separate dots with *
5. To configure default router choose option 2#. Separate dots with *
6. To configure subnet mask choose option 10# Separate dots with *.

VG248 Passthrough signalling

You can set passthrough signalling mode to
a. Legacy – Use with older VG248 software which runs only Legacy mode or with 6608 with older firmware or 6624-FXS
b. IOS mode – Use with ATA 186, 6608 with new firmware (new CM versions), all Cisco IOS routers or another VG248 with new software (1.2 or 1.3)

Fax key notes.

Fax key notes:
a. ata supports only fax passthrough (h323,mgcp or sccp)
b. 6608 supports cisco fax relay and passthrough. No support for t38.
c. ios gateways support all modes passthrough, relay, t38 (fxs)
d. vg248 supports all modes (passthrough, relay and t38). T.38 is available only on version 1.3(1)

VG248 Call Control Modes

a. standard – no need to use feature codes…features available are similar to feature mode.
b. feature – use feature codes for transfer and conference and other phone features. Use hookflash and feature code at the end to perform the operation (xfer, conf etc). With feature mode, there is independent control of each call leg.
c. basic – no transfer/conf. good for fax and modems
d. restricted  – most limited call mode. Used with billing system that begins charging when calls connect.
To change call control mode, go to each port, port specific parameters and enable the mode. default is standard.

Monday, August 22, 2011

Cisco Partner Enablement Event Trainings Seminars

Cisco Partner Enablement Event Trainings Seminars

Collaboration

Event Name
Materials
Date

Cisco Year-end Sprint: Collaboration


24-Nov-10

Unified CCX 8.0


12-Oct-10

Bandwidth Requirements in UCCE environment


7-Sep-10

Session Management Edition Webinar


20-May-10

UCC Express: Recording, Scripting and Outbound feature


11-May-10

UC Migration Support Program Report – Begin 2010


15-Apr-10

CVP 8.0 – Product Update session


08-Apr-10

UCCX 8.0 Update


18-Mar-10

Cisco User Connect Licensing


17-Mar-10

Cisco TelePresence Spring 2010 Launch for TelePresence ATP Partners


12-Mar-10

Cisco Unified Presence 7.x – India


4-Mar-10
5-Mar-10

UC on UCS (UC Virtualization – B&C Series)


25-Feb-10

Cisco Unified Communications Licensing


9-Feb-10

Cisco IPVS Products Overview


18-Feb-10

Cisco Unified Presence 7.x – Feb 2010


UC Rapid Deployment Method


4-Feb-10

Unified Contact Center Express (UCCX)


19-Jan-10

DMS 5.2 and MP Update


21-Jan-10

TelePresence Business Acceleration Launch


14-Jan-10

UCCX Demo Remote Capabilities


3-Dec-09

UCCX Design Best Practices


26-Nov-09

UC Migration to 7.x Hands-on


DialPlan Changes in CUCM 7.1


19-Nov-09

Cisco 2900/3900 Series as a UC Platform


Cisco Unified Contact Centre Express 7.x (UCCX) Hands-on – CHINA


CVP Self Service Update


5-Nov-09

CUPS – OCS Integration: Remote Call Control


4-Nov-09

Cisco Endpoint Update


29-Oct-09

UCS Services Session


26-Oct-09

Cisco Unified Contact Centre Express 7.x (UCCX) Hands-on – AUSTRALIA


UC Mobility Update


01-Oct-09

Cisco Unified Contact Centre Express 7.x (UCCX) Hands-on – ASIA


Speech Connect for Cisco Unity


24-Sep-09

UCCX 7.0 Features and Business Application Examples


17-Sep-09

Video Conferencing 7.0


03-Sep-09

Cisco Unified Communication Services – Cisco Essential Operate Services & UC Software Subscription


20-Aug-09

PDI Help Desk


20-Aug-09

Cisco UC Integration for Microsoft Office Communicator (CUCIMOC) Hands-on


11-Aug-09
12-Aug-09
13-Aug-09
25-Aug-09
26-Aug-09
27-Aug-09
28-Aug-09
08-Sep-09
09-Sep-09
10-Sep-09

VideoConferencing Update (CUVC5.7)


02-Jul-09

Contact Centre Update


02-Jul-09

CallControl Update


04-Jun-09

Presence & Clients Update


18-Jun-09

Cisco UC Integration with IBM


18-Jun-09

Cisco UC integration for MOC


18-Jun-09

Messaging Update


04-Jun-09

Endpoints Update


04-Jun-09

Virtualization

Event Name
Materials
Date

DC Management : An Oracle Perspective


9-Dec-10

Cisco Unified Compute System (UCS) and Cloud Update


9-Dec-10

Cisco Application Networking Update


9-Dec-10

Nexus 1000V Update


1-Dec-10

Cisco UCS YES Promotion


24-Nov-10

Cisco UCS YES Promotion


16-Nov-10

Services-Oriented SANs – Extend SAN Services to Any Device


10-Nov-10

Evolution Catalyst/Nexus


03-Nov-10

Getting Your Organization “Application Ready” in the Virtualization and Cloud Decade


27-Oct-10

DC Nexus Competitive Update


20-Oct-10

Asia Delivery of IBLM Account Analytics Get Refresh PAM/PSE Training


14-Oct-10

Winning 8GB Fabric Opportunities with 9148


13-Oct-10

Asia Delivery of IBLM PAM Training


13-Oct-10

Intel Roadmap and Competitive Update


08-Oct-10

IBLM Account Analytics Get Refresh Training


07-Oct-10

IBLM TTT PAM Training


06-Oct-10

End to End DC Arch with FabricPath & VPC


29-Sep-10

VCE Seamless Support


23-Sep-10

Free Netformx UCS Edition for UCS ATP Partners


16-Sep-10

Nexus (TTNX) inc 5500


15-Sep-10

Data Center Access: Catalyst 4900 Series Update


19-Aug-10

HA considerations for UCS Solutions


18-Aug-10

Introducing Data Center Service Node (DSN)


21-Jul-10

FCoE design and Case Studies


07-Jul-10

Impact of FCoE and Unified Fabric Opportunities


30-Jun-10

Data Center Switching Competitive Update


23-Jun-10

UCS Technical Positioning and Product Overview


16-Jun-10

INTEL Competitive update


19-May-10

Impact of FCoE and Unified Fabric Opportunities


12-May-10

WAAS Technology Update, Vision and Strategy


5-May-10

UCS versus HP Matrix – an architectural view


21-Apr-10

Extending Data Centers for Application and Server Virtualization


14-Apr-10

Data Center 3.0 Breakthrough: Innovations, Applications and Business Impact


07-Apr-10

ANM 3.0 – Intro to manage your virtual ACE load balancing environment


31-Mar-10

FCoE and its alternatives


24-Mar-10

NPV/NPIV explained what role UCS, MDS, and Nexus play


17-Mar-10

MDS 9148 Multilayer Fabric Switch


25-Feb-10

DC architectures and trends


24-Feb-10

Demonstrating and Configuring the Nexus 521 labs(India)


18-Feb-10
19-Feb-10

Utilizing Cisco and Fluke Networks Technologies to Deliver Application Performance-Based Services


10-Feb-10

Data Center trends and architectures


3-Feb-10

Cisco Discovery Tool Update


3-Feb-10

Demonstrating and Configuring the Nexus 521 labs(China)


28-Jan-10

Cisco Validated Design – Secure Cloud Solution from NetApp, VMware, and Cisco(English)


28-Jan-10

VCE / VBlock session


20-Jan-10

APAC Unified Data Centre SE Meeting


14-Jan-10
15-Jan-10

Demonstrating and Configuring the Nexus 521 labs(Pilot run)


13-Jan-10
26-Jan-10
27-Jan-10
29-Jan-10

VCE Vblock Technical Overview


13-Jan-10

APAC WAAS Assessment & WAAS Paid POC Program


17-Dec-09

ACE Integration into MS-Exchange Environment


16-Dec-09

APAC WAAS Assessment & WAAS Paid POC Program


15-Dec-09

APAC Unified Data Centre SE Meeting – India


14-Dec-09
16-Dec-09
17-Dec-09

Competitive Positioning of Nexus 7000


2-Dec-09

Overview of Achieving Success in Network Assessment with Netformx Enterprise AutoDiscovery DesignXpert


18-Nov-09

Nexus Access layer convergence


4-Nov-09

Nexus 5-2-1 Remote Lab TTT session


28-Oct-09

Intel’s latest processor technology and a peek into the near future


23-Oct-09

DC Webinar: ACE Positioning & Product Roadmap


14-Oct-09

WAAS Session#2


07-Oct-09

DC Webinar: Nexus 1000v Technical Training


23-Sep-09

DC Webinar: Overview of Nexus 1000V


16-Sep-09

WAAS Session#1


09-Sep-09

ACE


12-Aug-09

DC Webinar: N5K technical features and proof points for 10G access and FCoE v1.0


12-Aug-09

DC Webinar: Positioning the N7K into a Service Provider Network v1.0


05-Aug-09

Borderless Network

Event Name
Materials
Date

Security Demand Gen Program (Threat Defence) Overview


22-Dec-10

Security Demand Gen Program (Threat Defence) Overview


17-Dec-10

Juniper competitive training for Partners


15-Dec-10

Borderless Network Security Assessment (BNSA) Replay with live Q&A


07-Dec-10

Borderless Network Assessment – Security L4TM training (Pilot)


30-Nov-10

Borderless Networks – Mobility for All


25-Nov-10

Wireless Update for SMB/Midmarkets


23-Nov-10

Wireless Update for BFSI


16-Nov-10

Wireless Update for Enterprise/BPO


09-Nov-10

Cisco SA500 session


27-Oct-10

Wireless Update for Education


26-Oct-10

Harnessing the Power of Participation: Cisco Borderless Networks Architecture


20-Oct-10

Wireless Update for Government


19-Oct-10

Wireless update for Service Provider


12-Oct-10

Borderless Network Security Assessment (BNSA)


07-Oct-10

Catalyst 4500 Delivering Cisco Borderless Network Services


30-Sep-10

Borderless Network Access: Next Generation Catalyst 4500 Series Overview


29-Sep-10

Catalyst 6500 Borderless Services Node


22-Sep-10

Borderless Network in a Box: Catalyst 6500 IOS 12.2(33)SXI4 release


12-Aug-10

ISR G2 Product Update


15-Jul-10

Borderless Network SE Webinar:Catalyst 2K/3K Switching Deep Dive for EnergyWise


14-Jul-10

New Product Introduction launched under Borderless Network


10-Jun-10

Cisco Catalyst 4500 – What’s New


09-Jun-10

Cisco Mobility Motion Service: CleanAir


03-Jun-10

Cisco Catalyst 4500 – What’s New


02-Jun-10

The Premier Switching Foundation for BN Acess-Cat 4k Review


27-May-10

Cisco Catalyst 4500 – What’s New


26-May-10

Secure Borderless Networks with AnyConnect Mobile Security


20-May-10

Beating Juniper and Huawei: Cisco Competitive Strategies


13-May-10

BN SE Webinar_Cisco Medianet Technical Overview


22-Apr-10

ISRG2 3900E Series Technical Overview


15-Apr-10

TrustSec Solutions Partner Training


15-Apr-10
22-Apr-10
04-May-10

Catalyst 6500 Series Roadmap Update


08-Apr-10

Borderless Network Access: Better together with Cisco Wired + Wireless


01-Apr-10

Cisco Catalyst 2960-S and 3560-X/ 3759-X Series Competitive Advantage


11-Mar-10

EnergyWise Orchestrator Technical Overview


18-Mar-10

Cisco Catalyst 2960-S and 3560-X/ 3759-X Series Technical overview


4-Mar-10

Transforming the Branch Experience


23-Nov-09

Catalyst 6500 Series – Fast Forward Program


11-Nov-09

Catalyst 4500 Series – Energize with “E” Program


10-Nov-09

Unified Communications on the ISR G2


03-Nov-09

Integrated Security on the ISR G2


28-Oct-09

Borderless Networks & ISR G2 Announcement Update


22-Oct-09

Cisco Validated Design for the Branch


20-Oct-09

Borderless Network and Modular Switching


16-Oct-09

Introduction to the ISR G2


13-Oct-09

Cisco Adaptive Wireless IPS Solution – Wired-like Mobile Security


06-Oct-09

Cisco Wireless Control System – WCS 6.0


19-Aug-09

Catalyst 4500 Series and Catalyst 4900 Series Mini-Bootcamp – Catalyst 4900 Series Positioning and Architecture


16-Apr-09

Catalyst 4500 Series and Catalyst 4900 Series Mini-Bootcamp – PoE and Green


2-Apr-09

Catalyst 4500 Series and Catalyst 4900 Series Mini-Bootcamp – High Availability


26-Mar-09

Catalyst 4500 Series and Catalyst 4900 Series Mini-Bootcamp – Security and Identity


19-Mar-09

Catalyst 4500 Series and Catalyst 4900 Series Mini-Bootcamp – Catalyst 4500 Series Architecture


12-Mar-09

Catalyst 6500 Series Mini-Bootcamp Webex – Services Modules (including Firewall and ACE)


5-Mar-09

Catalyst 6500 Series Mini-Bootcamp Webex – Manageability


26-Feb-09

Catalyst 6500 Series Mini-Bootcamp Webex – High Availability


19-Feb-09

Catalyst 6500 Series Mini-Bootcamp Webex – Virtualization


12-Feb-09

Catalyst 6500 Series Mini-Bootcamp Webex – Catalyst 6500 Series Architecture


5-Feb-09

Campus Solutions Webex


15-Jan-09

Data Center Solutions Webex


8-Jan-09

Others

Event Name
Materials
Date

New Cisco product update ; 2960C switch, 1861-E routner, and WLAN


6-Jan-11

Partner Marketing Central launches Customized Marketing Application


10-Nov-10

Partner Program Intelligence Training for VIP16


20-Oct-10

Partner Program Intelligence Training for VIP16


19-Oct-10

Catalyst 2960-S, Catalyst 3560-X


15-Oct-10

Catalyst 2960-S, Catalyst 3560-X


14-Oct-10

Borderless Network 3.0 Launch training


23-Sep-10

Cisco Training on Upcoming Cisco Small Business Switching, Voice and Surveillance Solutions for Partners


22-Sep-10

AP 3500


21-Sep-10

Cisco Training on Upcoming Cisco Small Business Switching, Voice and Surveillance Solutions for Distributors


15-Sep-10

Partner Marketing Central Phase II – Application and Claims of Partner Co-Marketing Funds


15-Sep-10

AP 3500


8-Sep-10

VIP16 Partner Training


3-Aug-10

APAC Cisco Webcast for Partners: Cisco SB Update + Storage ‘Mini-Deep-Dive’


15-Jun-10

Cisco Education Campaign: Creating Connected Learning Societies


04-Jun-10

PDI Helpdesk


31-May-10

PE Tools: Steps to Success


5-May-10

Cisco Access Registrar – Overview


21-Apr-10

Partner Marketing Central – Partner Training


06-Apr-10
08-Apr-10

PEC


31-Mar-10

PDI Helpdesk


31-Mar-10

Cisco Small Business Webcasts for Partners


26-Feb-10

VIP15 Partner Training


2-Feb-10

TAC Session


22-Dec-09

SBR Workshop – WebEx – India


22-Dec-09

SBR Workshop – WebEx


17-Dec-09

Cisco Small Business Webcasts for Partners


15-Dec-09

Partner Helpline


10-Dec-09

Customer Satisfaction Requirements Training


1-Dec-09
3-Dec-09

Unified Communications Transforming Mid Market Accounts


28-Oct-09

Cisco Small Business Overview


06-Oct-09

Cisco Small Business Overview


Cisco Small Business Webcasts for Partners


Cisco Unified Communications Manager Business Edition For Partners

Partner N2A session